Besvarat

Huawei B2368: Low upload speed

  • 28 oktober 2020
  • 10 svar
  • 1271 visningar

To anyone who's considering Tre's "4G-utomhusrouter" aka. Huawei B2368. Do yourself a favor and don't bother. Even a mobile hotspot is able to provide a faster and more stable connection.

 

We have had Huawei B2368 since February, for exactly 8 months now. Download speeds are ok'ish around 10-30 mbit/s, but upload speeds are typically measured as 0.x mbit/s, comparable to modems we had in the 90's. And yes, I'm directly connected to the router with an ethernet cable when doing speed tests.

 

With these upload speeds, trying to send a file is painful. The other day I was trying to send a 8 MB file, first to SharePoint, then on Teams, but it always timed out in the middle until I gave up. It took about 2-3 seconds to upload the file via mobile hotspot. Ironically enough, the mobile subscription is from the very same operator, Tre. The reason why we chose Tre's mobile broadband in the first place was that the signal and speeds seemed to be fine with their mobile subscription. Well, it's _not_ the case with this "latest generation high-performance" outdoor antenna.

 

Whatever the speed measurement results are, the worst of all is that the connection is so unstable that it's often unusable. Attending video meetings is impossible, for example. It's better to switch to a mobile hotspot before video calls to avoid the embarrasment of not being able to follow the discussion, or even dropping out in the middle. Another major problem with such upload speed is that when there's basically any device in the house sending out data, the rest of the devices in the network are effectively crippled. Connections start timing out, because network requests don't go through. Try to send a file with Teams, and your e-mail client goes offline. So smooth is the experience with this world class 4G solution.

 

For what it's worth, the location of the antenna is as optimal as it gets. The antenna is at the top edge of a 7M high house roof. As requested by the Tre customer service, I have also tried moving the antenna around to "see if it works better on the other side of the house". So I have happily drilled holes and pulled cables around the house with no joy. In general, the experience with the customer service has been rather amusing. So far the problem has been blamed on the nearest site, something "cells" whatever that meant, antenna's location, missing 3G support, router's frequency, the hardware, and probably something else I already forgot. Funnily enough, when it was clearly reported to be a known problem with the nearest site, but the connection didn't get any better in a couple of weeks so I called yet again, the next customer agent was not aware of that there would have been an issue. But hey, they surely have managed to trick me to try various things, and months have passed without us getting a working connection.

 

I have lost track a long ago how many times I have called the customer service. I was already ready to terminate the contract on basis of all this. The response was that there's "no active case" so the contract cannot be terminated. That's right, apparently there's no issue here since it's not even worth opening a case. I should have returned the equipment right away during the first weeks, because it was already acting up, but somehow I was mistakenly blaming all these issues on masses of people working from home due to COVID, the network being overloaded, and what not.

 

Think twice before you invest to Huawei B2368 from Tre.

 

 

// Redigerat // - Ämnets titel har redigerats för att reflektera innehållet bättre - Ämnet har flyttats till bredband

icon

Bästa svar av Karl 29 oktober 2020, 10:51

Hi,

If you go to the UI of the router ( http://192.168.1.1/ if i remember correctly)

And use “Hi3G” as username and “CPE@huawei” as password.

Then go to network settings → broadband. 

You should be able to find something called “LTE Settings” Then choose “LockMode” “LockCell”.

On “Band” you type in “20”, on “DL EARFCN” you type “6200” and on “PCI” you type “51”.

If this doesn't help, try changing “PCI” to “257

 

I hope this helps. If not, send me a PM so i can look further into it what the issue might be.

 

(To any other reading this, the solution above is unique to jpnurmi)

 

My suspicion is that your B2368 is either hopping between different sites (causing the disconnect/connect issue) and using a Frequency that is not configured well to be used with uploading.

Visa original

10 svar

Användarnivå 3

Hi,

If you go to the UI of the router ( http://192.168.1.1/ if i remember correctly)

And use “Hi3G” as username and “CPE@huawei” as password.

Then go to network settings → broadband. 

You should be able to find something called “LTE Settings” Then choose “LockMode” “LockCell”.

On “Band” you type in “20”, on “DL EARFCN” you type “6200” and on “PCI” you type “51”.

If this doesn't help, try changing “PCI” to “257

 

I hope this helps. If not, send me a PM so i can look further into it what the issue might be.

 

(To any other reading this, the solution above is unique to jpnurmi)

 

My suspicion is that your B2368 is either hopping between different sites (causing the disconnect/connect issue) and using a Frequency that is not configured well to be used with uploading.

Thank you, Karl! I have applied the changes. I will report back later after seeing how it starts behaving.

Things were looking promising with PCI 51. Upload speeds were definitely better, somewhere around 20 mbit/s.

 

Until on Monday evening it dropped the connection. The signal indicator light was blinking orange - no LTE signal. I tried restarting the router a couple of times and then switching to PCI 257, but still no signal. After disabling the LTE lock mode, a signal was found again. Sometime later I tried switching back to PCI 51 and then it found the signal again.

 

During the week it was fine, but now the same thing happened again and the light started blinking orange. Right now it's in a state that neither PCI 51 nor PCI 257 finds any signal. The only way to bring it back online is to disable the LTE lock. The signal light is constantly at orange and we are back to crawling speeds (0.6 mbit/s down, 10 mbit/s up).

 

Monday

3867    Nov 2 21:22:48    info    LTE Has Disconnected, debug info: F_CAMP=1, F_IP=1, info.rssi=N/A, info.conn=1
3868    Nov 2 21:22:51    info    [L2TP] L2TP Tunnel Down.
3869    Nov 2 21:22:53    info    (0) APN-1 doesn't disconnected (1)
3870    Nov 2 21:22:58    info    (1) APN-1 doesn't disconnected (1)
3871    Nov 2 21:23:03    info    (2) APN-1 doesn't disconnected (1)
3872    Nov 2 21:23:08    info    (3) APN-1 doesn't disconnected (1)
3873    Nov 2 21:23:13    info    (4) APN-1 doesn't disconnected (1)
3874    Nov 2 21:23:19    info    (5) APN-1 doesn't disconnected (1)
3875    Nov 2 21:23:24    info    (6) APN-1 doesn't disconnected (1)
3876    Nov 2 21:23:29    info    (7) APN-1 doesn't disconnected (1)
3877    Nov 2 21:23:34    info    (8) APN-1 doesn't disconnected (1)
3878    Nov 2 21:23:36    err    Disconnect: cause #0, n/a [last message repeated 1 times in 0 seconds]
3879    Nov 2 21:23:36    err    Disconnect: APN-1, cause #0, n/a [last message repeated 1 times in 0 seconds]
3880    Nov 2 21:23:44    info    LTE Module is in power-saving or sleeping mode [last message repeated 25 times in 127 seconds]
3881    Nov 2 21:25:52    info    [LAN] (null) [88:3d:24:9c:dd:xx] got IP:192.168.1.35
3882    Nov 2 21:25:56    info    LTE Module is in power-saving or sleeping mode [last message repeated 10 times in 50 seconds]
[...]

Friday

994    Nov 6 20:10:17    info    LTE Has Disconnected, debug info: F_CAMP=1, F_IP=1, info.rssi=N/A, info.conn=1
995    Nov 6 20:10:22    info    (0) APN-1 doesn't disconnected (1)
996    Nov 6 20:10:23    info    [L2TP] L2TP Tunnel Down.
997    Nov 6 20:10:27    info    (1) APN-1 doesn't disconnected (1)
998    Nov 6 20:10:32    info    (2) APN-1 doesn't disconnected (1)
999    Nov 6 20:10:37    info    (3) APN-1 doesn't disconnected (1)
1000    Nov 6 20:10:42    info    (4) APN-1 doesn't disconnected (1)
1001    Nov 6 20:10:48    info    (5) APN-1 doesn't disconnected (1)
1002    Nov 6 20:10:53    info    (6) APN-1 doesn't disconnected (1)
1003    Nov 6 20:10:58    info    (7) APN-1 doesn't disconnected (1)
1004    Nov 6 20:11:03    info    (8) APN-1 doesn't disconnected (1)
1005    Nov 6 20:11:05    err    Disconnect: cause #0, n/a [last message repeated 1 times in 0 seconds]
1006    Nov 6 20:11:05    err    Disconnect: APN-1, cause #0, n/a [last message repeated 1 times in 0 seconds]
1007    Nov 6 20:11:13    info    LTE Module is in power-saving or sleeping mode [last message repeated 39 times in 197 seconds]
1008    Nov 6 20:14:35    info    [LAN] DESKTOP-XXX [00:e0:4f:6a:2b:xx] got IP:192.168.1.51
1009    Nov 6 20:14:36    info    LTE Module is in power-saving or sleeping mode [last message repeated 10 times in 50 seconds]
[...]

After restart

2    Jan 1 08:00:23    info    TR069Init(334): SN 868817031488669
4    Jan 1 08:00:24    info    Searching for LTE Signal... [last message repeated 1 times in 5 seconds]
7    Jan 1 08:00:34    info    Searching for LTE Signal... [last message repeated 7 times in 36 seconds]
8    Jan 1 08:01:15    info    LTE Module is in power-saving or sleeping mode
9    Jan 1 08:01:19    info    Temperature=26.6°C
10    Jan 1 08:01:20    info    LTE Module is in power-saving or sleeping mode
[...]

 

The router has been in non-locked mode until the morning. Now the locked mode works again too.

Results:
- non-locked mode: download: 24,36 Mbit/s, upload: 0,82 Mbit/s
- locked mode with PCI 51: download: 2,05 Mbits/s, upload: 23,01 Mbit/s
- locked mode with PCI 257: no signal - blinking orange light
 

Seems pretty inconsistent. The issue is not resolved.

It lost the signal again and started blinking orange whilst locked to PCI 51.

59	Nov 7 14:59:07	info	LTE Has Disconnected, debug info: F_CAMP=1, F_IP=1, info.rssi=N/A, info.conn=1
60 Nov 7 14:59:11 info [L2TP] L2TP Tunnel Down.
61 Nov 7 14:59:12 info (0) APN-1 doesn't disconnected (1)
[...]

 

Användarnivå 3

Hi,

I can see that the cell tower using 51 was having some issues during last week.

One time during Monday, one time during Friday to Saturday and once again during Saturday. Does that seems to match the periods where it stopped working for you?

I will check with some of our network people what the issue might be and see if it is completely resolved now.

 

// Karl

Användarnivå 3

Hi,

The issue is supposed to be completely resolved now according to the network people.

The first issue you were experiencing was due to a transmission problem and the second time you had the issue was due to a reboot we performed on the cell site supposed to resolve the issue.

 

// Karl

Alright, I have switched back to 51. The time periods match. Quite a coincidence that this happened right after enabling the lock. :)

Are there problems again? The light is blinking orange.

Användarnivå 3

Hi,

 

Yes, there were some issues between 11:00 - 12:00 but should be working right now.

 

// Karl

Svara